Get in touch
Back
Downtime

Client payment validation (suspends clients if they don't pay) is down

Started 14 Dec at 10:19pm CET, resolved 15 Dec at 10:42am CET.

Resolved

Client payment validation (suspends clients if they don't pay) recovered.

Posted 15 Dec at 10:42am CET.
Created

Client payment validation (suspends clients if they don't pay) went down.

Posted 14 Dec at 10:19pm CET.