Get in touch
Back
Downtime

Client payment validation (suspends clients if they don't pay) is down

Started 17 Apr at 11:50am CEST, resolved 17 Apr at 11:55am CEST.

Resolved

Client payment validation (suspends clients if they don't pay) recovered.

Posted 17 Apr at 11:55am CEST.
Created

Client payment validation (suspends clients if they don't pay) went down.

Posted 17 Apr at 11:50am CEST.